When configuration is complete, your mobile device should be able to connect to the StayLinked server and see an emulation screen.
Windows 10 and Windows Mobile Device Center (WMDC)
The following steps can sometimes be helpful if you are having an issue with WMDC creating a connection to any device:
From a command prompt, run the two following commands separately:
REG ADD HKLM\SYSTEM\CurrentControlSet\Services\RapiMgr /v SvcHostSplitDisable /t REG_DWORD /d 1 /f
REG ADD HKLM\SYSTEM\CurrentControlSet\Services\WcesComm /v SvcHostSplitDisable /t REG_DWORD /d 1 /f
Open Windows Services, (command services.msc) and make the following changes:
- Edit the service ‘Windows Mobile-2003-based device connectivity’
- Go to the Recovery tab
- Subsequent Failures set to Restart the Service
- Edit the service ‘Windows Mobile-based device connectivity
- Go to the Recovery tab
- Subsequent Failures set to Restart the Service
Restart your PC for the changes to take effect.
Be sure to follow Microsoft instructions and troubleshooting steps before applying the changes listed above. These steps should only be required on Windows 10 systems that can no longer use WMDC. If you are not sure, we recommend following the manual installation instructions for any client instead of tampering with the Windows registry.
If your function keys do not work as expected, be sure to confirm your emulation settings as described in the section regarding your telnet host entry. If the keys do not work after starting a new session, refer to the technical reference on keyboard maps for a list of common alternative keyboard mappings.
Basic Error Message Codes
If you don’t see an emulation screen on your device, the message displayed should point to the possible causes. The following are the most common examples:
| Issue/Error | Solution |
|---|---|
| Not a Valid Windows CE Application | This message is typically displayed when the wrong client has been loaded on your device. Some manufacturers also include resource files that are required for the StayLinked client to run. Please confirm the client matches your hardware and device operating system. Contact support for further details. |
| Out of Range |
This message appears when the device operating system reports that it is not associated with an access point. In most cases, this means the radio has not been configured for your network. If the radio has been configured and can be contacted with a network ICMP ping, then you can set the client to ignore the association status. To disable out of range detection, scan the first barcode for the setting and then restart the client by scanning into the StayLinked client scan test.
|
| Error: Host Timeout | This message appears when the client was unable to complete the connection handshake with the server. This can be caused by entering the wrong address or port for the StayLinked server, attempting to connect to a server that is not running, incorrectly configured network or security settings, firewalls that block UDP protocol, and routing and other network-related issues. Please review the Technical Reference for Host Timeout or call support if the error persists. |
| Blank Screen | After the client displays the "connected" message, you might be presented with a blank screen if the device is reporting invalid screen dimensions or if the iSeries subsystem you are connecting to has not been started. We recommend entering fixed rows and columns for the display in the StayLinked configuration, and then contacting your iSeries administrator if you are using 5250 emulation. |
Once connected to the StayLinked server, the server may display several different error messages on the device. These message codes mean the device connected to the StayLinked Server just fine, but the Server cannot create a session because of the issue described with the code.
| Message | Solution |
|---|---|
| eSP0001 No Hosts Defined |
No Host defined in the StayLinked Administrator. Use the StayLinked Administrator to define Telnet hosts. |
| eSP0002 Host Not Responding |
Bad Host address or port. Confirm the Host address and Telnet port information in the Telnet Host configuration. Host might be unreachable on the network. Confirm that the Telnet Host is currently available on the network. |
| eSP0003 No Keymap Found |
This Device Type is not cross referenced to a keyboard map for this Host Emulation. Use the StayLinked Administrator to add a keyboard map for this Device Type and Host Emulation combination. Possible unknown Device Type. |
| eSP0004 Bad License Key Authentication Error Admin. Config. Error No TE Seats Available No Multi Seats Available |
Use the StayLinked Administrator to review the license information. Does the key refer to the correct Server Serial Number? For iSeries Platforms, the STAYLINKED user profile might be disabled or have no password. Review the STAYLINKED user profile. |
| eSP0005 WSID Not Available |
The 5250 session is unable to allocate the specific device description. The device description on the AS/400 does not exist or is not varied on. Or, the device description has no interactive subsystem in which to run. |
| eSP0006 Device Not Allowed Device Group Is Full Blowfish Required |
The device is assigned to a Device Group that is set to not allow connections or has a maximum session limit defined. See "Manage Device Groups" in the Administrator User Guide. The server is configured to require Blowfish Encryption and the StayLinked Client does not support that encryption. See "Server Settings" in the Administrator User Guide. |
| eSP0007 Client Not Compatible |
eSP-Link clients are not compatible with StayLinked Servers. |
| eSP0008 Could not get device config. |
The server was unable to communicate with the device to retrieve the device configuration. Probable network traffic problems. Simply re-attempt the connection. |
| eSP0009 Multi Sessions Denied |
The device is a member of a Device Group that does not allow multi sessions. Review the device group settings for this device. |
| eSP0010 Unable to connect to Shared Session |
The server was unable to connect to the shared session. Simply re-attempt the connection. |
| eSP0011 SSH Errors |
Bad SSH User/Password SSH Password Expired Unsupported Authentication SSH Disconnected |
| eSP0012 SSH Not Supported |
SSH Support for StayLinked requires at least Java JRE 1.4.2-06 and the latest StayLinked Support JAR files. |
| eSP0013 SSH Logon Cancelled |
The user cancelled the SSH logon prompt screens. |
| eSP0014 SSL Errors |
Server Cert. Not Trusted Client Cert. Not Provided Client Cert. Not Found Client Cert. Bad Password |
| eSP0015 Device Not DM Capable |
The device is not capable of running a DM Only session. You must install the StayLinked Device Management Components onto the device to make it capable. |
Demo Mode
Brand new installations of the Server process will include a ‘Demo Mode’ license. This allows the server to support up to three connections for a one-hour period. Once the hour is up, the server process must be restarted to start a new hour. When a client connects to the server with the demo key, it will display StayLinked Demonstration Mode and press any key. It will also display the time remaining in demo mode or a notification that the server process has expired. Restarting the server process will start a new hour. Send your server serial number to our support team to obtain standard licensing.
Share the post "Troubleshooting and Error Messages"